Upgrade Samba su Snow Leopard

Me & My Mac
by Martin Gommel

Dopo una lunga e sofferta serie di tentativi sono finalmente riuscito nell’intento e quindi è meglio che lo condivido, così nel caso mi dovesse ri-servire almeno so dove trovarlo! Il problema è il seguente: a casa ho un WD TV Live media center che ha sempre lavorato egregiamente. Da qualche tempo però lamentavo dei problemi sulla lettura delle cartelle condivise dal mio iMac. Anzi, non vedevo praticamente più l’iMac! Cerca e porcheggia in giro finchè non trovo la causa: ho fatto un paio di aggiornamenti del firmware e a quanto pare gli ultimi firmware utilizzano delle funzionalità di samba non più compatibili con la versione montata da Apple. Che strano, mi dico, e così controllo: Apple monta la versione di samba 3.0.28 ovvero piuttosto vecchiotta. Che a quanto pare, oltre a non andare con il mio media center, non va neppure con Windows 7. Il motivo lo leggo sul forum di supporto di Apple: dalla versione 3.2.x samba è passato alla licenza GPLv3 che è molto più restrittiva della GPLv2. E quindi Apple si è fermata con gli aggiornamenti. Leggi il resto dell’articolo

Annunci